AI Loop

Locked
Spleenling
Posts: 3
Joined: Fri Mar 10, 2017 4:07 am

AI Loop

Post by Spleenling » Fri Mar 10, 2017 4:14 am

The Wives in all my villages are either Getting resources for the household and never taking the finished Product to the town center or doing nothing but Delivering Resources to the town center and never getting Wood/Food for the household. This is rendering progression impossible without me providing Every resource myself.

Edit: This bug persists even if I go from 1.7.10 to 1.6.4

Spleenling
Posts: 3
Joined: Fri Mar 10, 2017 4:07 am

Re: AI Loop

Post by Spleenling » Fri Mar 10, 2017 5:19 am

Here is the Text dump for the Byzantine wife:

native_name=Gynaika
gender=female
familyNameList=greek_family_names
firstNameList=greek_women_names
baseheight=0.9
health=20
malechild=boy_byzantine
femalechild=girl_byzantine
tag=seller

model=femaleasymmetrical

texture=textures/entity/byzanz/female/byz.female.A.png
texture=textures/entity/byzanz/female/byz.female.B.png
texture=textures/entity/byzanz/female/byz.female.C.png
texture=textures/entity/byzanz/female/byz.female.D.png
texture=textures/entity/byzanz/female/byz.female.E.png
texture=textures/entity/byzanz/female/byz.female.F.png
texture=textures/entity/byzanz/female/byz.female.G.png
texture=textures/entity/byzanz/female/byz.female.H.png
texture=textures/entity/byzanz/female/byz.female.I.png
texture=textures/entity/byzanz/female/byz.female.J.png
texture=textures/entity/byzanz/female/byz.female.K.png
texture=textures/entity/byzanz/female/byz.female.L.png
texture=textures/entity/byzanz/female/byz.female.M.png
texture=textures/entity/byzanz/female/byz.female.N.png

clothes=free,textures/entity/byzanz/female/clothes/byz.defaultwife.1.A.png
clothes=free,textures/entity/byzanz/female/clothes/byz.defaultwife.1.B.png
clothes=free,textures/entity/byzanz/female/clothes/byz.defaultwife.1.C.png
clothes=free,textures/entity/byzanz/female/clothes/byz.defaultwife.1.D.png
clothes=free,textures/entity/byzanz/female/clothes/byz.defaultwife.1.E.png

clothes=clothes_byz_wool,textures/entity/byzanz/female/clothes/byz.defaultwife.2.A.png
clothes=clothes_byz_wool,textures/entity/byzanz/female/clothes/byz.defaultwife.2.B.png
clothes=clothes_byz_wool,textures/entity/byzanz/female/clothes/byz.defaultwife.2.C.png
clothes=clothes_byz_wool,textures/entity/byzanz/female/clothes/byz.defaultwife.2.D.png

toolNeeded=clothes_byz_wool

goal=gorest
goal=gosocialise
goal=chat
goal=gopray
goal=deliverResourcesShop
goal=GetHouseTHResources
goal=getGoodsHousehold
goal=deliverGoodsHousehold
goal=plantvines
goal=harvestvines
goal=makewine
goal=makesouvlaki

goal=buildpath
goal=clearoldpath

goal=makedirtwall
goal=makepathdirt
goal=makepathgravel
goal=makepathochretiles

requiredFood=cider,5
requiredFood=calva,2
requiredFood=rasgulla,1
requiredFood=wine,1
requiredFood=feta,1
requiredFood=cake,1
requiredFood=cookie,5
requiredFood=cacauhaa,1
requiredFood=sake,1

baseAttackStrength=2
defaultweapon=woodaxe

User avatar
Xour
Posts: 293
Joined: Mon Jun 16, 2014 10:29 am

Re: AI Loop

Post by Xour » Sat Mar 11, 2017 12:56 pm

It's less likely a problem with the wife than it is the shop itself, go to the same cultures/byzantine folder and look at the shops, in each one there should be a section called, deliverto= followed by a list of resources that should be delivered to the shop. If there isn't re-download the mod. if that isn't it then could you post a copy of the millenaire.log its located in the main millenaire folder. Another possibility is that the people aren't collecting the resources themselves ,have you mad sure the workers are actually performing there tasks? Hope this helps.

Spleenling
Posts: 3
Joined: Fri Mar 10, 2017 4:07 am

Re: AI Loop

Post by Spleenling » Sun Mar 12, 2017 7:18 am

Somehow replacing the Millenaire folder with a fresh copy fixes the bug, but only for the first world I create. If I make another world both worlds develop the glitch.
Also log from world with bug:

6.0.0 12-03-2017 13:18:32 Starting new session. Mods: examplemod
6.0.0 12-03-2017 13:18:39 ERROR: null: Tried to create good from block with no item: saddle;73;0;Selle
6.0.0 12-03-2017 13:18:44 ERROR: grosbourg: Could not recognise parameter ?name: ?name:GrosBourg
6.0.0 12-03-2017 13:18:44 ERROR: null: No name found for village: grosbourg
6.0.0 12-03-2017 13:18:44 MAJOR: null: Loading language: en_US
6.0.0 12-03-2017 13:18:44 MAJOR: null: Language loaded: en_US. Wand name: Wand of Summoning Wand invitem name: item.ml_villageWand.name

Bosscrafter73
Posts: 48
Joined: Sun Jan 15, 2017 5:48 pm

Re: AI Loop

Post by Bosscrafter73 » Sun Mar 12, 2017 2:32 pm

Spleenling wrote: 6.0.0 12-03-2017 13:18:32 Starting new session. Mods: examplemod
6.0.0 12-03-2017 13:18:39 ERROR: null: Tried to create good from block with no item: saddle;73;0;Selle
6.0.0 12-03-2017 13:18:44 ERROR: grosbourg: Could not recognise parameter ?name: ?name:GrosBourg
6.0.0 12-03-2017 13:18:44 ERROR: null: No name found for village: grosbourg
6.0.0 12-03-2017 13:18:44 MAJOR: null: Loading language: en_US
6.0.0 12-03-2017 13:18:44 MAJOR: null: Language loaded: en_US. Wand name: Wand of Summoning Wand invitem name: item.ml_villageWand.name
What other mods are you using? This may be a case of mods interfering with each other.
Head Millenaire Dev,
Bosscrafter73
Make sure to report any bugs you find on the Official Bug Tracker!
Official Millenaire Discord Server

Locked